John the Ripper CE Auditing Tool

John the Ripper CE Auditing Tool

Install latest/stable of John the Ripper CE Auditing Tool

Ubuntu 16.04 or later?

Make sure snap support is enabled in your Desktop store.


Install using the command line

sudo snap install john-the-ripper

Don't have snapd? Get set up for snaps.

Channel Version Published

John the Ripper password security auditing and recovery tool

John the Ripper is a fast password cracker, currently available for many flavors of Unix and for Windows. Its primary purpose is to detect weak Unix passwords. Besides several crypt(3) password hash types most commonly found on various Unix systems, supported out of the box are Windows LM hashes, various macOS password hashes, as well as many non-hashes such as SSH private keys, encrypted filesystems such as macOS .dmg files and "sparse bundles", encrypted archives such as ZIP, RAR, and 7z, encrypted document files such as PDF and Microsoft Office's, plus lots of other hashes and ciphers.

Details for John the Ripper CE Auditing Tool

License
  • GPL-2.0

Last updated
  • 14 May 2019 - latest/stable
  • 1 February 2024 - latest/edge

Websites

Contact

Source code

Share this snap

Generate an embeddable card to be shared on external websites.


Install John the Ripper CE Auditing Tool on your Linux distribution

Choose your Linux distribution to get detailed installation instructions. If yours is not shown, get more details on the installing snapd documentation.


Where people are using John the Ripper CE Auditing Tool

Is there a problem with John the Ripper CE Auditing Tool? Report this app